In some cases, we release an update for LinkFixer Advanced that is "required". We have only done this a few times in rare cases where we discovered a serious functional issue that could damage user files. We require the update in these circumstances in order to reduce or eliminate the possible danger.


Other types of updates can be installed at your convenience. LinkFixer Advanced will continue to remind you about the available update whenever you launch LinkFixer Advanced.


Please accept and immediately install any required updates.


If there is some reason you absolutely cannot install a "required" update, please contact a support agent to discuss the options.